•   over 4 years ago

bigR Machine Learning. (does it work ?)

I've downloaded and installed the "bigr" package in my mac. I'm using Rstudio.
I can connect to the bluemix, but there are a lot of functions that don't work, for example "bigr.boxplot"
Actually this one is not on the documentation of the package I've installed but is on the bluemix example:

https://developer.ibm.com/hadoop/docs/biginsights-value-add/big-r/bigr-tutorial/

In additon I've just received an email from "CallangePost" that talk about some ML algorithms, like: bigr.svm, bigr.lm, etc.
But none of those are on the bigr library
The post is here:

http://ibmhadoop.challengepost.com/updates/2654-tips-for-developing-with-big-r?utm_campaign=big-data-for-social-good_20141013&utm_content=challenge_update&utm_medium=email&utm_source=update

I've tried with more "traditional" libraries, like "caret", but of course it doesn't work, I get this error:

Error in as.data.frame.default(data) :
cannot coerce class "structure("bigr.frame", package = "bigr")" to a data.frame

All in all, "bigr" looks like a good Idea, poorly developed. More over, it does not work not event the step by step demo on IBM "how-to"

:-(

Any suggestions before I completely abandon this ?

thanks
angelo

  • 16 comments

  •   •   over 4 years ago

    Hi Angelo,

    First thank you for trying out Big R.

    We took a look at the issues you brought up and here are the answers:

    1) The bigr.boxplot needs extra R packages (ie. ggplot2) to run so we have deprecated it on our Big R package. Once the extra R packages are installed, the function can still be invoked by bigr:::bigr.boxplot(). The tutorial was run on an earlier version of bigr. We will update our tutorial to reflect this.

    2) The Big R Client package you downloaded from the WebConsole link was an older version bigr package unfortunately. We are fixing the problem. Once it is fixed, we will post an update. For the time being, if your blumix instance has been successfully activated, you can try the Ad hoc R script Application through the WebConsole to run the new ML functions.

    These functions are available only if you "Activate" your instance to participate in the Social Good challenge. You can tell if your instance has been successfully activated by checking the expiry date. It should be beyond end of April.

    3) It looks like you were running as.data.frame.default() function on a bigr.frame. I believe that it has the same functionality as as.data.frame(). In Big R, we support as.data.frame() instead of as.data.frame.default().

    Sorry for the troubles you have encountered.

    Adrian

  •   •   over 4 years ago

    Hi Angelo,
    Can you provide us the console URL of your cluster? We will fix the client package for you. You can get it by clicking on the Show Credentials on your bluemix dashboard 'analytics for hadoop' service icon. It will be of the form https://bi-hadoop-prod-xxx.services.dal.bluemix.net:8443/

    Thanks,
    Kulki

  •   •   over 4 years ago

    bi-hadoop-prod-457.services.dal.bluemix.net

  •   •   over 4 years ago

    Thanks Angelo. We will test internally, then fix it and will let you know.

  •   •   over 4 years ago

    any update?

  •   •   over 4 years ago

    I just updated your cluster. Pls give it a try. The downloaded package size should be 5012492

  •   •   over 4 years ago

    Now I can see on the "help" the basic ML functions. Thanks

  •   •   over 4 years ago

    I downloaded the BigR package from webconsole using the quick links (Download client library and development software) and the selecting the BigR client. It downloaded bigr-1.0.tar.gz to my Windows PC. The size of this file is 4,954,209 bytes ( Size on disk - 4,956,160 bytes).

    The above seems to be no different than the bigr package that I downloaded on 12/16/2014. I compared the file sizes and they are identical.

    Could you point me to the right download link/location for the updated bigr package?

    My console URL is https://bi-hadoop-prod-345.services.dal.bluemix.net:8443/data/html/index.html

  •   •   over 4 years ago

    In MY case, I downloaded from the bluemix console, and although the version DIDN'T change, the new ML functions are there, along with the documentation :-)

  •   •   over 4 years ago

    By bluemix console, I am thinking you mean the BigInsights web console, is that right? I get to this web console page by clicking launch on the Hadoop For Analytics service page.

    Or are you referring to something else?

  •   •   over 4 years ago

    Yes, it is exactly that.

  •   •   over 4 years ago

    The fix was applied only to the one instance bi-hadoop-prod-457. The general fix will be applied to all service instances some time next week. Wil apply the fix to bi-hadoop-prod-345 today. Please trt again in an hour

  •   •   over 4 years ago

    I tried again and this time I found the updated bigr package. Thanks for your help.

  •   •   over 4 years ago

    I still see the old Package, can you apply the fix to bi-hadoop-prod-862 as well
    thanks

  •   •   over 4 years ago

    The Challenge has ended. Did you register and use the "authorization code" to "Activate" your Bluemix Analytics For Hadoop instance?

  •   •   over 4 years ago

    I missed out on the date, Do you have any other challenges ? or is it possible get pacakge any other way so that i could use it on BigInsigts VM ware ?

Comments are closed.